Symptom
When a workflow is sent back to the initiator, the initiator is unable to update the fields of the workflow due to visibility settings in the BCUI.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors Employee Central Workflows
Reproducing the Issue
- Select the sent back workflow and click on update to edit the fields.
- Notice that the fields are not editable.
Cause
The field is set to visible only in BCUI and the flag respectRBP=no.
Resolution
If the field is set to visible only in Manage business configuration, kindly set the flag to "respect RBP = yes", to edit the fields in the workflow.
See Also
Keywords
workflows, respect permission functionality, workflow RBP, manage business configuration RBP settings, role-based permissions in workflows, respectRBP. , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , How To
Product
SAP SuccessFactors Employee Central 2505