SAP Knowledge Base Article - Public

3626724 - SCIM2 API not working for 'Groups' returning HTTP 500 error in SAP Analytics Cloud (SAC)

Symptom

SCIM2 API not working for 'Groups' - GET - https://<HostName>/api/v1/scim2/Groups returning HTTP 500 error

Environment

SAP ANALYTICS CLOUD 2025.8.6

Reproducing the Issue

  1. Get request to token url with Authorization: Basic Auth; Username: OAuth Client ID value; Password: Secret value HEADERS: x-sap-sac-custom-auth:true; Content-Type:application/json
  2. In the returned json result, copy the value from access_token.
  3. GET request to https://Tenant FQDN/api/v1/scim2/Users Authorization: Bearer Token; Token: access_token value which is get in step 3.
    HEADERS: x-sap-sac-custom-auth:true; Content-Type:application/json; x-csrf-token:fetch 
  4. Get the expected result
  5. Change the request URL to https://Tenant FQDN/api/v1/scim2/Groups
  6. The following error is shown
    {
    "schemas": [
    "urn:ietf:params:scim:api:messages:2.0:Error"
    ],
    "status": "500",
    "scimType": "",
    "detail": "An internal error occurred."
    }

Cause

  • One of the teams created for migration purposes incorrectly contain some API ACCESS users 
  • The API ACCESS users interfere with the Groups endpoint because when trying to fetch a Group, the API also fetches all the team members. But, because API ACCESS users are not supported in teams, the request throws an error.

Resolution

Remove the API Access users from the problematic team.

See Also

Keywords

API, SCIM API, SAC, groups, users, response, get, post, patch , KBA , LOD-ANA-LS , Licensing and Full User Equivalent , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0