SAP Knowledge Base Article - Public

3626808 - When Searching For Products Under Sales Quote Document Using Category ID The Result Is Wrong

Symptom

When searching for "0123" product category as example, under sales quote document on Products facet, it is showing other category ID on the list result. e.g: "0456"

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Go to Sales then Sales Quotes work center view.
2. Open "ABC" sales quote.
3. Go to Products facet.
4. Click on Add button.
5. Open the Products field.
6. Search for "0123" category ID.
7. You can see 3 products with "0123" category ID and a wrong entry appearing with "0456" category ID.

Cause

The Basic Search being used in this scenario, which searches over various fields of the product, not just the categories.

In the given example, searching for "0123" returns the products with "ABC", "DEF" and "GHI" ID's.
While for product ID ABC and DEF, this seems to fit to the category (0123), for product ID GHI is returned, as there's a customer part number "9801230456" in the sales data.

So the search result is correct.

Resolution

If the expectation is to show results based on categories only, the Advanced Search has to be used, where search data can be entered field specific.
This search would return only products with the mentioned category (or sub category, if wanted).

Keywords

Category ID; Search; Result; Products; Wrong; C4C; Quotes; Appearing; Showing , KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2505