Symptom
- Attempt to permanently delete a position
- Receive error: "You can't delete the position because employee null has already been assigned to it on date x..."
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Manage Positions
- Check affected position
- Take Action > Permanently Delete the position
- Receive the error
Cause
Subject user of the workflow in pending status was assigned to the position but is now purged
Resolution
- Go to Admin Alerts page
- Search for Admin Alert "Workflows with Deleted Subject User"
- Search for the same effective date that shows in the error message
- Click on the workflow and action it to resolve the error
See Also
Keywords
You can't delete the position because employee null has already been assigned to it, delete, position, subject user, pending workflow, sentback workflow, position workflow, purged user, deleted user , KBA , LOD-SF-EC-POS-WFL , Position Workflows , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem
Product
SAP SuccessFactors Employee Central all versions