Symptom
The Time Type External Code is not visible in the Time Sheet UI for the Employee Self-Service (ESS) scenario. However, it is visible in the Manager Self-Service (MSS) scenario or when logged in as an admin user.
Reproducing the Issue
- Proxy as employee
- Open employee's Time Sheet UI
- Click on Record either Working Time, On-Call or Allowance time type
- The External Code for time types are not visible in the dropdown menu
Cause
This is the current expected behaviour. We received pushback from several customers in response to our new feature — Minor Functional Changes on the Time Sheet UI. They wanted to hide the External Code of Time Types and Allowance Types, as it does not provide much value and would allow them to streamline the information presented on the UI. Therefore, it has been removed from the Employee Self-Service (ESS) scenario.
Resolution
The external code of time type is now only visible in the Manager Self-Service (MSS) scenario.
Keywords
external code, time type, allowance type, ESS, Time Sheet UI, TIM-45451, TIM-49412 , KBA , LOD-SF-EC-TMS-UI , UI - Errors, Trace, RBP, Permissions, Status , LOD-SF-TTR-TMS , Time Sheet , Problem
Product
Attachments
working time external code missing.png |