SAP Knowledge Base Article - Public

3627234 - Team Absence Calendar shows "Please wait a moment while we load the data" and does not load

Symptom

  • Some users in the same team have no initial visibility when they select "View Team Absences".
  • The message "Please wait a moment while we load the data." but data does not load.
  • Users can search for their colleagues and see the data using the search bar.

Environment

  • SAP SuccessFactors Employee Central - Time Off

Reproducing the Issue

  1. Proxy as affected user.
  2. View Team Absence Calendar.
  3. See message "Please wait a moment while we load the data." but nothing happens.

Cause

  • Issue caused by employee time external codes containing special characters.
  • Only letters (A-Z), numbers (0-9), dashes (-), and underscores (_) are allowed when setting up your external codes. Any other special characters like +, /, ?, &, %, and # are not supported and will cause errors.

Resolution

  1. Ensure that only letters (A-Z), numbers (0-9), dashes (-), and underscores (_) are used when setting up external codes.
  2. Remove any special characters like +, /, ?, &, %, and # from external codes.

See Also

https://help.sap.com/docs/successfactors-time-tracking/implementing-time-management-in-sap-successfactors-083e8bcccdbc40249f82a5e4b1efcfdc/recommendations-and-restrictions-for-time-off#restrictions 

Keywords

team absence, empty list, view team absences, sap successfactors, employee central, time management, time off, external codes, special characters, error message, data loading, search bar, visibility issue , KBA , LOD-SF-EC-TIM-UI , Team Absence Calender/ Workbench/ ESS UI's , Problem

Product

SAP SuccessFactors Employee Central all versions