Symptom
Not all Accounts are shown in the map view when using the SAP Sales Cloud APP on an IOS device.
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2
- SAP Sales Cloud Mobile App - IOS
Reproducing the Issue
- Log in to the SAP Sales Cloud App
- Navigate to the Accounts
- Click the map view
- Some accounts didn't display on the map view
Cause
- Apple's location API has a limit on how many addresses can be processed in a short period of time. When too many requests are sent at once, some may fail. In this case, the remaining requests are placed in a queue and processed once the API can process requests again.
- If the address is incomplete or incorrect and the coordinates can’t be found, the account won’t be displayed.
Resolution
- Verify if the account address location can be displayed correctly on Apple and Google maps.
- Ensure that the address information is complete and accurate.
- Limit the map filters so that only the current user’s accounts ("my accounts") are shown to reduce the number of addresses processed by the API.
Keywords
Mobile, Accounts, Map view, SAP Sales Cloud, Address, Location, IOS, SAP Sales Cloud Version 2, SAP Service Cloud Version 2, SAP Sales Cloud App , KBA , CEC-CRM-MOB-IPH , iPhone Native App for SAP Sales/Service Cloud , Product Enhancement
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public