SAP Knowledge Base Article - Public

3627488 - Deleted column still appears in on-prem Extractor logs as NULL as <deleted column name>

Symptom

When a column is deleted from a table configuration in a Source Data instance and that table is subsequently extracted, NULL as <deleted column name> may be seen in the On-prem Extractor logs.

Cause


NULL as "<deleted column>" in the logs indicates that the column was removed from the table, but the table has not being cleaned (old data removed). The system will continue to keep extraction files backward compatible by pulling all known column. Those that were deleted are set to NULL on that position. 

Resolution

To remove references to deleted columns in the logs, perform a table data deletion following the steps here: Deleting Data or Table in Standard Extraction | SAP Help Portal 

The option to remove old data (clean up) serves 2 purposes:
  • Delete the extracted data (nothing will be deleted if nothing has been extracted)
  • Remove completely any column which was marked as deleted from the table in the configuration.
     

    See Also

    Help reference for managing tables and columns: Managing Tables for Data Extraction | SAP Help Portal 

    Keywords

    soe,Process,Intelligence, PDM, Source,Data,Table,Column,deleted,NULL,extractor,on-prem,log  , KBA , BPI-SIG-PI-DM , Data model / ETL for SAP Signavio Process Intelligence , Problem

    Product

    SAP Signavio Process Intelligence all versions