Symptom
When custom workflow notification triggers for adding concurrent employment, template received shows the data of the existing employment instead of concurrent employment.
Environment
- SAP SuccessFactors Employee Central - Concurrent Employment
- SAP SuccessFactors Employee Central - Workflows
Reproducing the Issue
Prerequisites
Workflow configuration with approval involved should trigger when adding concurrent employment along with custom workflow notification template
Steps:
- Go to employee profile
- Take action -> Add Concurrent Employment
- Fill in the mandatory details
- Submit
- Workflow triggers
- Approver received the pending approval notification with custom workflow template however data in the template does not belong to concurrent employment instead it comes from existing employment.
Cause
- In standard email notification, Employment & Job Information details are derived from the workflow attributes table. So, standard emails will have the same values as of the workflow request.
- In custom email notification, the resolved id is the main user Id (existing employment). Due to direct mapping, the values are retrieved from the Employment & Job Information tables. Hence, you will see the details of the existing employment in the custom mail received.
Resolution
Engineering team has confirmed this is an expected behavior when you have a custom workflow template with direct mapping.
Workaround:
Use Standard email notification.
(OR)
Use Reference mapping however you will have limited tags just like standard email notification.
See Also
Keywords
concurrent, employment, Employment,Concurrent, custom workflow notification,custom, Custom, Workflow, email,Email, Notification, incorrect, wrong, details, old, existing, standard, mapping, direct, reference, Add Concurrent Employment, add concurrent employment, add, template, Template, docgen, Document, document, generation, Generation, INC13295457 , KBA , LOD-SF-EC-CON , Concurrent Employment , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , How To
SAP Knowledge Base Article - Public