SAP Knowledge Base Article - Public

3628396 - Business Partner Address Format Differs Based on Country

Symptom

Business Partner displays address fields in a different sequence based on the country.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to Maintain Business Partner app.
  2. Open the Business Partner.
  3. Navigate to the standard address.
  4. Click on the Print Preview.

Cause

This is a system standard behavior.

Resolution

SAP follows the standards of the Universal Postal Union for the format of an Address and a Postal code for member countries.

  • Addresses are formatted based on valid national and international guidelines - Print formatting for addresses.
  • For addresses where the recipient country and the sender country are different, the city and the country lines are printed in uppercase - Basic Pattern.
  • The format of the address depends on whether the sender and the recipient country are identical or not. If the countries are not identical, the country is always indicated, either by its full name or by its vehicle country key. If the sender country and the receiver country differ, the system will always print the address in the language of the sending country since the delivering postal service needs to be able to read the country name - Country Formatting.

Refer this documentation for more details : List of Address Layouts.

Keywords

business partner, address sequence, country format, sap s/4hana cloud, universal postal union, print formatting, basic pattern, country formatting, address layouts , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , BC-SRV-ADR , Address Management / Business Address Services , Problem

Product

SAP S/4HANA Cloud Public Edition all versions