Symptom
- You notice inconsistent behaviours on Sales Quote form template
- In some cases, Ship-To Address is on the form and in some cases, Ship-To Address is not on the form
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center
- Go to the Sales Quotes work center view
- Open Sales Quote 123 (Where 123 refers to the Sales Quote ID, and Ship-To and Sold-To Addresses are the same)
- Click Preview in the Actions
- A form is generated without Ship-To Address
- Open Sales Quote 987 (Where 987 refers to the Sales Quote ID, and Ship-To and Sold-To Addresses are the same)
- Click Preview in the Actions
- A form is generated with Ship-To Address
Cause
- Ship-To Address is on the form if Ship-To Address and Sold-To Address are different. If the Addresses are the same, it shouldn't be on the form so the Step 5 in the Steps to Reproduce is a correct behaviour, and the Step 8 is an incorrect behaviour
- On the Standard Sales Quote Form Template, address lines of the Ship-To and the Contact are compared and based on the comparison, Ship-To Address is on the form or not
- When there is Additional Name(s) for the Account, the address line comparison does not work as designed, so the incorrect behaviour occurs
Resolution
An attribute AddressSnapshotUUID can be used to compare the addresses. If the addresses of the Ship-To and the Buyer are the same, these attributes match: $.FormQuote.ProductRecipientParty.FormAddress.AddressSnapshotUUID and $.FormQuote.BuyerParty.FormAddress.AddressSnapshotUUID, so create a Custom Form Template and implement the below code.
if ( $.AddressSnapshotUUID_Ship_to == $.AddressSnapshotUUID_Sold_to ) then
$.parent.frmShipToAdd.presence = "hidden"
endif
Keywords
ship-to, ship to, address, additional address, form template, inconsistent, preview, sold-to, sold to, buyer, contact , KBA , LOD-LE-CQP , Customer Quote Processing , Problem