Symptom
- You see some Visits are locked by SAP_SYSTEM with error message: Locking object not possible; object locked by SAP_SYSTEM (SAP_SYSTEM)
- You also see there are many changes in the Changes facet of Visit by SAP_SYSTEM but without any details
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Visits work center
- Go to the Visits work center view
- Open Visit 123 (Where 123 refers to the Visit ID)
Result: An error message occurs.
Cause
Visits are Perfect Store Visits and;
- An Engagement Map is not associated with the Account of the Visit in the Customers facet in the Engagement Map or by a Target Group
- No Engagement Map maintained at all
Note
- The issue is specific to Perfect Store Visits
- These are the possible causes and your issue might be caused by something else
Resolution
If there is an active Engagement Map but it is not associated with the Account.
- Go to the Activity Planner work center
- Go to the Engagement Maps work center view
- Open the Engagement Map
- Go to the Customers facet
- Maintain the Account
or
- Follow the above step 1 - 3
- Go to the Target Groups facet
- Open the Target Group
- Go to the Members facet
- Maintain the Account
If there are no Engagement Maps. Maintain an active Engagement Map and associate with the Account in the Engagement Maps work center view.
See Also
Keywords
visit, lock, locked, sap_system, engagement map, perfect store , KBA , LOD-LE-PSP , Perfect Store , LOD-CRM-ACT-VST , Visit Planning , Problem
Product
SAP Cloud for Customer core applications all versions