SAP Knowledge Base Article - Public

3628812 - Extension Field Value Does not Carry from Service Request to Service Quote

Symptom

Extension field ABC has been activated for both service requests and service quotes. Service quote DEF, which created as a follow-up to service request XYZ, does not carry over ABC's value from service request XYZ.

Where:

  • ABC is the ID of the relevant extension field.
  • DEF is the ID of the relevant service quote.
  • XYZ is the ID of the relevant service request.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to work centre: Service Desk.
  2. Select view: Service Requests.
  3. Click New -> Service Request button.
  4. Maintain all the relevant details, including a value for ABC.
  5. Submit the document.
  6. Take note of the ID from the message prompt, e.g. "Service request XYZ saved successfully".
  7. Now return to the Service Requests OWL.
  8. Select XYZ, then Follow-Up -> Service Quote.

Observe in the New Service Quote screen the extension field ABC is not populated.

Cause

There is no extension scenario available between service requests to service quotes.

Resolution

This is the expected system behavior. If a service quote is created as a follow-up to a service request, any extension field values must be input manually into the new service quote.

See Also

Extension Scenarios

Keywords

extension field, service request, service quote, scenario, manual, expected, behavior, SAP Business ByDesign, extension scenario. , KBA , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign all versions