Symptom
A Process Communication Error occurs for a sales order with the following message:
"Role Account for ABC not permitted; legal competence not set in master data (KBA: 3046914)". (Where ABC represents the Account's ID)
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Sales Orders workcenter.
- Go to the Sales Orders view.
- Search for the ID XYZ (Where XYZ stands for the relevant Sales Order ID).
- Click on Edit.
- Click on View All.
- Go to the Document Flow tab.
There is a Process Communication Error. Clicking on the red icon, the below message is displayed:
"Sales Order XYZ cannot process an update sent by a Customer Demand".
- Navigate to the Application and User Management workcenter.
- Go to the Business Data Consistency view.
- Go to the Process Communication Errors sub view.
- From the drop-down, select Open Errors with Cases.
- Open the Advanced Search (the little funnel icon).
- Search for the ID XYZ.
The Main Error information is the following:
"Role Account for ABC not permitted; legal competence not set in master data (KBA: 3046914)".
Cause
The issue occurs because the Legal Competence checkbox was unchecked on the Account ABC master data at some point of the sales process, after the sales order was released. As a consequence, an inconsistency is created.
ndicates that the business partner is a legal entity from a financial view point and therefore able to enter into a contractual agreement. This means that, this checkbox must be marked if we want to add this account to any Sales Document (Sales/Service Order, Customer Contracts...).
Should the Legal Competence indicator be disabled on the account master data, its ID will not even be visible when trying to enter it on new documents.
Resolution
Aiming to clear the inconsistency from the document, the following steps must be performed to the master data:
- Navigate to the Account Management workcenter.
- Go to the Accounts view.
- Search for ID ABC.
- Click on Edit -> General.
- Mark the checkbox 'Legal Competence'.
- Click on Save.
Once the Legal Competence is properly set to the business partner, raise a case to SAP Product Support so that the failed communications can be restarted and delivered from the backend level.
See Also
KBA 3046914 - Role Account for XYZ not permitted; legal competence not set in master data
Keywords
Process Communication Error, sales order, legal competence indicator, account master data, cannot process an update sent by a Customer Demand, byd. , KBA , AP-SLO-SO , Sales Order , Problem
SAP Knowledge Base Article - Public