SAP Knowledge Base Article - Public

3629565 - OAuth connection to third-party application fails with the error message "The SSL connection could not be established, see inner exception" in SAP Analytics Cloud

Symptom

  • You set up an OAuth Client and generate an OAuth token to connect to a third-party application for data export purposes, which fails sometimes with the following error message:
    • "The SSL connection could not be established, see inner exception"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Analytics Cloud 2025.8.13 

Cause

This behavior is currently by design. After 24 hours, the SAC OAuth Token for the OAuth Client will expire. This time limit is not adjustable in SAC to expire in more than 24 hours. 

The connection will fail when the third-party application does not automatically generate a new OAuth token after the 24-hour expiration period. Authentication attempts will fail until a new token is generated, after which the connection succeeds. 

Resolution

The third-party app team should be contacted, as it is a third-party tool not managed by SAP.

The application code needs to be changed in order to get a new OAuth token before trying to authenticate again past the 24-hour expiration period.

See Also

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Keywords

OAuth, token, SAC, expiration, 24 hours, client, export, connection, third-party, OAuth token, OAuth Client, authentication , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0