SAP Knowledge Base Article - Public

3629841 - Product Description Language Not Changed With Logon Language

Symptom

  • Product description language does not change based on the logon language.
  • It does not dynamically change based on the user's selected login language. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log into system in language A and add a product in Ticket, see that Product Description field is in language A as expected. Log off.
  2. Log into system in language B. Open the Ticket, see that the Product Description field is not displayed in language B but still in language A.

(A and B represent different languages.)

Cause

Different from UI language, system stores Product Description field language according to the language in which the product is added.

Resolution

    This is the current expected behavior of SAP Cloud for Customer.

    If the feature/functionality is required urgently, please refer to KBA 0003475641 - Functionality Currently not Available. 

    An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea: 

    Keywords

    product description, logon language, product field, dynamic language change, description field, language discrepancy , KBA , LOD-CRM-SRP , Service Request Processing , How To

    Product

    SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions