SAP Knowledge Base Article - Public

3629926 - Work Zone API issue with subcategories having the same name

Symptom

  • There is a problem, with Work Zone API when subcategories have the same name.
  • When searching on the categories, only one of the categories can be found

Image/data in this KBA is from SAP internal systems, sample data, or systems. Any resemblance to real data is purely coincidental.

 

Environment

  • SAP SuccessFactors Work zone
  • SAP Build Work zone, Advanced Edition

Reproducing the Issue

  1. Go to Administration Console.
  2. Choose Knowledge Base.
  3. Tap on "Categories" and observe the issue.

Cause

  • The issue was caused by a limitation in the system when subcategories have the same name.

Resolution

  • Engineering team confirmed that it's not recommended to use the same category name.
  • The API will always return the articles in the first category it found with the category name.
  • If desired functionality is needed, please raise it as an enhancement request on the Influence portal.

See Also

KBA 2090228 How to Submit Ideas for SAP SuccessFactors Products

Keywords

work zone, api, subcategories, same name, processes, performance management, articles, limitation, enhancement request, influence portal , KBA , LOD-SF-SWZ-DEV , Custom Development and API concerns , LOD-SF-JAM-DEV , Custom Development - API request & Issues , Product Enhancement

Product

SAP SuccessFactors Work Zone all versions