Symptom
All new instances of Mass Data Runs are failing.
The Job Logs of the failed runs are like this, for example:
- Job started
Step 001 started (program SAP_MDRI_REPORT, variant , user ID K0123456789)
01.01.2000 00:00 CET
MDRO: YABCDEFGH_BOABCDFGH12345678 (/YABCDEFGH/R2, 00000000000000000000000000000077052)
01.01.2000 00:00 CET
Error: Error during invocation of FPP service CREATE_EXECUTION_NODE; action failed
01.01.2000 00:00 CET
Error: A severe (system) failure occurred in the remote call
01.01.2000 00:00 CET
Error: RFC Message: The application running deliberatelycaused an abort with short dump.
01.01.2000 00:00 CET
Error: Severe (system) failure occurred
01.01.2000 00:00 CET
Error: MDRO creation (execution node) failed
01.01.2000 00:00 CET
Error: Missing application log indication
01.01.2000 00:00 CET
MDRO executed with error(s)
Important log:
- Error: Error during invocation of FPP service CREATE_EXECUTION_NODE; action failed.
Environment
- SAP Cloud Applications Studio
- SAP Cloud for Customer
- SAP Business ByDesign
Reproducing the Issue
- Schedule a new MDRO.
- See that it fails.
- Check the logs.
- Observe the job logs for errors related to CREATE_EXECUTION_NODE and severe system failures.
Cause
The system tries to create a node for an MDRO but cannot due to the limit being exceeded. There may be a huge number of MDRO instances in the tenant.
Resolution
Delete all unused MDRO instances to free up storage for new Mass Data Runs.
See Also
Refer to the documentation about Mass Data Run for deletion guidelines:
Ensure the solution is in maintenance mode before deletion, to know more about maintenance mode:
Keywords
background run, sdk jobs failing, mdro instances, exceeded limit, missing application log, mass data run, deletion, deliberately caused, deliberately, caused , KBA , AP-RC-BDS-MDR , ByDesign Studio Mass Data Run , Problem
SAP Knowledge Base Article - Public