Symptom
- When the condition of a workflow rule is satisfied, email notification is not received by the user maintained.
- Cannot add a certain user as a recipient when maintain workflow rule.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management - Workflow Rules.
- Find and open the issued workflow rule.
- Go to Define Action.
- Try to set a certain user as recipient in this workflow rule.
- The user is missing from value help.
Or
- When a configured workflow rule is satisfied, the recipient cannot receive the e-mail notification.
Cause
The target user is password inactive.
Resolution
- Go to Application and User Management.
- Find the issued user and click Edit -> Attribute.
- Input an initial password in the Password field.
- Save the changes.
- Then the user can be added in the workflow rule as a recipient.
Or if the user is already added in workflow rule as a recipient but cannot received the e-mail notification when the workflow rule is satisfied, remove the user from the workflow rule and add it again.
Keywords
E-mail Notification not Triggered, E-mail Notification not Received, Workflow Rule, Password Inactive , KBA , AP-RC-OUT-EVT , ByD: Event Notifications , SRD-CC-IAM , Identity & Access Management , Problem
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public