SAP Knowledge Base Article - Public

3630164 - E-mail Notification do not Trigger for a User Maintained in Workflow Rule or a Certain User cannot be Added as a Recipient in Workflow Rule

Symptom

  • When the condition of a workflow rule is satisfied, email notification is not received by the user maintained.
  • Cannot add a certain user as a recipient when maintain workflow rule.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management - Workflow Rules.
  2. Find and open the issued workflow rule.
  3. Go to Define Action.
  4. Try to set a certain user as recipient in this workflow rule.
  5. The user is missing from value help.

Or

  1. When a configured workflow rule is satisfied, the recipient cannot receive the e-mail notification.

Cause

The target user is password inactive.

Resolution

  1. Go to Application and User Management.
  2. Find the issued user and click Edit -> Attribute.
  3. Input an initial password in the Password field.
  4. Save the changes.
  5. Then the user can be added in the workflow rule as a recipient.

Or if the user is already added in workflow rule as a recipient but cannot received the e-mail notification when the workflow rule is satisfied, remove the user from the workflow rule and add it again.

Keywords

E-mail Notification not Triggered, E-mail Notification not Received, Workflow Rule, Password Inactive , KBA , AP-RC-OUT-EVT , ByD: Event Notifications , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Business ByDesign all versions