Symptom
You would like to change the name of a record from Primary Emergency Contact (PerEmergencyContacts).
If you try to upsert using a new name via OData API, it will create a new record instead of updating existing record.
Environment
SAP SuccessFactors HCM
- OData API
Cause
"name" is a Business Key field from "PerEmergencyContacts" entity.
You cannot uppdate the Business Key field to another value for an existing record.
Resolution
For API, you could first delete the existing record, and then create a new record.
Or you may update the name field directly under Primary Emergency Contact in the UI.
Keywords
Emergency Contact, relationship, required field, change, overwrite, incremental purge , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-ODATA , OData API Framework , Problem
SAP Knowledge Base Article - Public