SAP Knowledge Base Article - Public

3630316 - Incompleteness error for field Follow-up Activity in App Manage Customer Returns - Version 2

Symptom

System throws an error saying, 'Follow-up activity is incomplete', even though it is filled through Custom BADI.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Implement the BADI SD_SLS_MODIFY_RETURNS_ITEM.
  2. In this BADI, modify/fill the field customerreturnitem_out-custretitmfollowupactivity.
  3. Create a returns order.
  4. Even though the BADI fills the field customerreturnitem_out-custretitmfollowupactivity, the returns order cannot be released because it throws an incompleteness error.
  5. Save the returns order.
  6. After saving, the system recognizes the input in the field customerreturnitem_out-custretitmfollowupactivity and the returns order can be released now.

Cause

Cloud BADI fields with Incompleteness Info function is missing and it is a program error.

Resolution

The issue will be fixed, and the feature will be added in 2602 Release.

Till the time, follow the below Workaround.

  1. First click "Save" button then click "Release" button to use (OR)
  2. Manually add the Refund Control field or any other field. Then click on Save and Release.

Keywords

follow-up activity, incompleteness error, returns order, BADI, SAP S/4HANA Cloud Public Edition, refund control, customerreturnitem_out, save and release , KBA , SD-SLS-RE-2CL , Returns (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions