SAP Knowledge Base Article - Public

3630694 - An internal error appears when submitting the manual I-9 form during the E-Verify process - Onboarding.

Symptom

An "Internal Error" message appears upon submitting the manual I-9 form for new hire, preventing the completion of the I-9 compliance process. 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

1. Navigate to Create E-Verify
2. Search for the user
3. Complete the required fields
4. In List B, select the document presented as Driver's License Receipt
5. Fill in the remaining fields
6. Click Submit
7. Observe that an "Internal Error" appears upon submission

Cause

E-Verify does not accept receipt documents for Driving License.  In this case, using List B: RECEIPT_REPLACEMENT_US_DRIVERS_LICENCE is not a valid scenario for E-Verify, and attempting to submit with this document type will result in an error.

Resolution

This behavior is expected with E-Verify, as the system does not support the use of document receipts for verification. E-Verify requires original documents to complete the process. 

See Also

3354642 - When submitting an E-Verify Case receiving an error that says "An internal error occurred while submitting the case." - Onboarding

Keywords

Manual E-verify, E-verify, I-9, Onboarding 2.0, Internal error, Onboarding, OBX , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding all versions