SAP Knowledge Base Article - Public

3630907 - C4C Registered Warranty Information is not updated with S4 Equipment Integration

Symptom

Registered product warranty not updating in the integration scenario with S4.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Administrator and the view Web Service Message Monitoring.
  2. Search for the related message that will be in successful state.
  3. Check the payload, it contains the warranty start and end date.
  4. However the same is not updated in C4C.

Cause

In registered product in C4C, a calculation of both start and end date takes place. The End Date calculation in Registered product is done based on the Reference date and duration. It is not based on Start Date.

Resolution

When you replicate a warranty from ERP system, the warranty end date is getting cleared because start date and end date are passed in the payload ( with a blank value corresponding to warranty end date ). If you do not want to manually set the start/ end date then these values need to be left blank in the payload.

Other than that, recalculation of end date is triggered when you update any one of the two fields:

1) Reference Date

2) Warranty ID

If none of them are changed then date calculation will not be triggered. 

Keywords

registered product, warranty, integration, s4, wrong dates, not replicated , KBA , LOD-LE-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer core applications 2505