SAP Knowledge Base Article - Public

3631174 - Capacity Scheduling Table Runtime Error RAISE_EXCEPTION

Symptom

  • The Capacity Scheduling Table app is not functioning as expected.
  • Runtime Error: 'RAISE_EXCEPTION'. The OData request processing has been abnormally terminated. Analyze the runtime error using Feed Reader in ABAP development tools for Eclipse or using transaction /IWFND/ERROR_LOG or /IWBEP/ERROR_LOG or ST22.

Environment

SAP S/4HANA Cloud Public Edition.

Reproducing the Issue

  1. Open the Capacity Scheduling Table app.
  2. Select a resource or work center.
  3. Observe that:
    • The app returns no data or fails to load.
  4. Runtime Error: 'RAISE_EXCEPTION' occurs.

Cause

The runtime error is caused by an inconsistency in the work center configuration.

Resolution

  1. Verify the factory calendar assigned to the affected work center in the Work Center Capacity Header. The issue occurs when the factory calendar assigned is not defined in Activity 'Maintain Calendar'.
  2. Use Activity 'Maintain Calendar' to check if the assigned Factory Calendar exists.
    • If it does not exist, either:
      • Create calendar as required, or
      • Assign a valid, existing factory calendar to the work center.
  3. Alternatively, if the work center is not required for capacity scheduling:
    • Remove the affected Work Center from the selection in the app.

Once corrected, the Capacity Scheduling Table app should display data correctly and allow strategy saving and rescheduling operations.

Keywords

capacity scheduling, sap s/4hana cloud, runtime error, raise_exception, factory calendar not found, work center pxl1, capacity scheduling table, capacity scheduling board, data not loading, strategy not saved, rescheduling not possible, browser issue, saplcrk1, SAPLCRK1, FACTORY_CALENDAR_NOT_FOUND , KBA , PP-CFS-SCH-2CL , Capacity Scheduling (Public Cloud) , PP-BD-WKC-2CL , Work Center (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions