SAP Knowledge Base Article - Public

3631183 - The Account's e-mail address changes to Reporter's e-mail inside Ticket

Symptom

When a Reporter e-mails the e-mail channel which automatically creates Service Tickets upon, the Involved Parties section pulls in an Account if the sender's e-mail is associated with a Contact and linked to an Account.

The problem is that the Account listed in the Involved Parties within the Service Ticket is automatically changing the e-mail address of the Account to match the Reporter's e-mail. This happens whether the Account has a listed e-mail or not. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service> Tickets.
  2. Open the desired one.
  3. In Overview facet scroll down.
  4. See Involved Parties section.
  5. See Reporter and Account both have the Reporter's e-mail address displayed.
  6. Now open the Account.
  7. See the e-mail from header is correct.

Why the e-mail address from Account is being override for the Reporter's e-mail inside Ticket?

Cause

System is taking the e-mail address from the Contact of the Account that opened the Ticket. 

The Account in question have the Reporter party added as a Contact inside Contacts tab. It is not the Main Contact of the Account, however since this is the Contact from Account that opened the Customer Support Ticket, it will link the Account's e-mail with the party linked with both Customer and Ticket. That is why it is overriding the Account's e-mail inside Ticket.

In such scenarios, the Involved Party determination for Reported inside Ticket will probably be "10 Copied from Partner Contact"

This can be checked by following below steps:

  1. Go to Business Configuration> Overview
  2. Search for Ticket for Customer Support
  3. Click on Maintain Involved Parties
  4. Select Reporter row and click on Maintain Determinations button

 It is also possible to see that for that Ticket, the Reporter determination method will be "Copied Automatically from a Party with a Different Party Role Category". This can be seen by following:

  1. Go to Administrator > General Settings
  2. Click on Check Party Determination
  3. Select Ticket object
  4. Enter the Ticket ID and click Go
  5. Go to Header Parties facet
  6. See Reporter line

This means party determination "10 Copied from Partner Contact" is taking place here. This will take the e-mail from the Party/Contact of Account that opened the Ticket, not the e-mail from the Main Contact.

Resolution

This is the expected system behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.  

See Also

KBA 3475641 - Functionality Currently not Available. 

Keywords

email, service request, inbound, outbound, modifying, modification, changed, modified , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SC-EML , Email , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions