SAP Knowledge Base Article - Public

3631491 - Behavior of Account Search in the OVS Screen of Task Workcenter.

Symptom

When we perform advance search to filter primary Contact in Task WC, the result set provides all the contacts.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP Cloud for Customer.

Reproducing the Issue

  • Navigate to Task>Create New task
  • Click on to primary contact and open OVS Screen 

  • Click on advance search and select Account

  • The search result provides all the contacts.

Cause

Since the account OVS is used twice. Once directly and once inside the Primary Contact OVS. As the same UI component is loaded twice, this is the behavior in selecting from the list. 

Resolution

This is an expected behavior.

As a workaround directly add the Account ID in the advance search of primary contact screen and click on go to get the correct result set.

Keywords

Advance search ,contact,OVS, /BYD_COD/SalesOnDemand/Contact/UI/COD_Contact_SOVS.OVS.uicomponent , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer core applications 2505

Attachments

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