Symptom
The customer contract Validity status is "Not Started" instead of "Expired", even though the Contract End Date is in the past.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Sales Orders workcenter.
- Go to the Contracts view.
- Search for the ID XYZ (Where XYZ represents the Contract ID).
- Click on Edit.
- Click on View All.
Cause
The Validity status is Not Started because one or more contract line items have this status. Although the date ABC has passed, the line item is not Expired because it was cancelled while the contract was still In Preparation status (not released yet).
In this case, the Cancellation Effective Date was reached before the contract release. Therefore, the item was never valid because the validity had not even started at the moment of cancellation.
Note: The system takes a while to properly cancel the line item after the cancellation is requested (1 or 2 minutes). Once this is done, the document must be refreshed or closed and opened again. Then, the item Cancellation status will turn from Cancellation Requested to Canceled, and the item will be Completed.
Resolution
This is the expected system behavior. Once an item is completed, it is not possible to change its statuses.
If it is desired to cancel a line item and keep it with Expired status, it must be canceled after the contract is released, this way, the validity goes from "Not Started" to "Active" and then to "Expired" following the correct flow.
Keywords
Customer Contracts, end date, validity, status, not expired, cancelation reason, byd. , KBA , AP-CCP , Customer Contract Processing , How To
SAP Knowledge Base Article - Public