Symptom
TXT record and email domain are one to one correspondence so you don't have to repeat to add the TXT record on all your instances however, doing so fails for some instances.
Environment
SAP SuccessFactors HCM suite
Reproducing the Issue
- Enter Manage E-Mail Notifications
- Click at manage domains "Add"
- Enter the email domain in domain field and click Verify.
Cause
TXT generated previously before B2505 have leading zeros where verifying the same TXT record on another instance post B2505 removes the leading zeros which causes the issue.
Resolution
You would need to add a new TXT record for the other instance, the two instance would have two different DNS record.
See Also
Keywords
domain verification failed, new domain, manage email notifications, unable, unable to verify, email domain, TXT record. , KBA , LOD-SF-PLT-NOT , Email Notifications , Problem
SAP Knowledge Base Article - Public