SAP Knowledge Base Article - Public

3631927 - Upgrade to talent intelligence hub is stuck in progress

Symptom

  • Upgrade to Talent Intelligence Hub still in progress.
  • All successful but the LMS_MIGRATION=INITIATED
  • The "Growth Portfolio Permission" is also not yet visible.
  • Scheduled Job Manager displaying:
    Current state is External Module Check Some required module migrations is not completed {RCM_MIGRATION=SUCCESS, PMU_MIGRATION=SUCCESS, COC_PORTFOLIO_MIGRATION=NOT_APPLICABLE, CDP_MIGRATION=SUCCESS, OMA_MIGRATION=SUCCESS, JPB_MAPPINGS_MIGRATION=SUCCESS, LMS_MIGRATION=INITIATED}, please look for next latest job with type WSMMigrationJob latest further status

Environment

Talent Intelligence Hub

SAP SuccessFactors Learning

Reproducing the Issue

  1. Go to Upgrade center
  2. Check the TIH upgrade.

Cause

  • One of the causes of the job stuck in Progress could be
  • An instance refresh was performed where only BizX was refreshed and LMS was not
  • If TIH is involved and customer had migrated earlier, they need to refresh both the systems before triggering the migration.
  • Refreshing only 1 will leave the system in inconsistent state.
  • Even certain flags are clear in LMS, it will leave the system in inconsistent state that cannot be fixed (data flows across the systems and will lead to duplication of records).

Resolution

  • For BizX environments integrated with Learning, the instance refresh must be performed where both Learning and BizX are refreshed together.
  • Please refer to the Refresh KBAs under See Also section for more details if desired.

See Also

Keywords

upgrade, talent intelligence hub, in progress, growth portfolio permission, SAP SuccessFactors, LMS job, TIH enablement, migration, inconsistent state, refresh, duplication of records , KBA , LOD-SF-LMS-TIH , Talent Intelligence Hub , Problem

Product

SAP SuccessFactors Learning all versions