Symptom
In the Talent Pool there is a mismatch in the Talent Pool's member count and it shows more candidates than those that are actually listed. When looking at the candidate profiles it can be seen that some of them have been added to the same Talent Pool more than once.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
There are two (or more) Saved Searches linked to the same Talent Pool. e.g. Saved Search “Country US” and Saved Search “First Name Test”.
When candidates create a candidate profile and select the values for the fields selected for the two Saved Searches at the same time, then they will be added to that Talent Pool twice. I.e. when the candidate creates the profile and selects US as a Country and Test as the First Name at the same time (or on the same day, before the Add Candidate to Pool job runs at night time), then this candidate will be added twice to the same Talent pool.
- Go to the External Career Site
- Create a new candidate profile
- Enter “Test” as the First Name and US as the Country
- Wait for the job Add Candidate to Pool in Provisioning to run at nighttime
- The next day you will see on the candidate profile that this candidate was added twice to the same Talent Pool
Cause
This was checked by engineering and has been confirmed to be expected behaviour due to a limitation of the product.
Resolution
Engineering are working on enhancing the product to resolve this limitation. If you would like to follow the enhancement please contact your account manager and give them this internal ticket number RCM-153301.
Keywords
talent pool, duplicate candidates, incorrect count, sap successfactors, visibility settings, gateway recruitment, saved searches, code defect, candidate relationship management , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem
SAP Knowledge Base Article - Public