Symptom
Integration Center Calculated Filter field value calculation is not working when we set "Field Value=<Now>" and we compare this date with a Date field.
You are getting the records in the Preview section but when you actually run the IC job the record is not included. The logs show "No of Records Processed in this batch - 0" even though when we check in the Calculation Trace of Calculated filter the record condition is set as true and we can see the record in the Preview
Disclaimer: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- Integrations
- Integration Center
- Integrations
Reproducing the Issue
- Go to Integration center
- Create a new integration, select the starting entity and required fields as per your requirement
- Go to "Filter and Sort" and Click on Calculated Filter
- Create a Calculation as shown in the Screenshot
- Where you Select the Data Type as DateTime and add the fieldvalue as <NOW> for the Field Value
- When you check the Configure Fields, you will see the Preview Records, but when they actually run the IC job the record is not included and Execution logs show "No of Records Processed in this batch - 0" even though you can see the record in the Preview.
Cause
By default, FieldValue - <Now> is treated as a string, which results in a string comparison rather than a date-time comparison.
Resolution
To resolve the issue you will have to Use <TODAY> instead of <Now> , as it will compare the Date at runtime it will execute the Integration Center Job as expected.
Please Note: In preview output may differ since it consider browser timezone and not Tenant Timezone.
See Also
Keywords
integration center, LOD-SF-INT-INC-FWK, Calculated Filter, Date Comparison, Now, Today, No of Records Processed in this batch - 0 , KBA , LOD-SF-INT-INC-FWK , Integration Center UI Framework , LOD-SF-INT-INC , Integration Center , LOD-SF-INT-INC-JOB , Integration Center Job , Problem
Product
Attachments
| Pasted image.png |
SAP Knowledge Base Article - Public