Symptom
When adding an item in solution orders or service documents (e.g. service orders, service quotations), the language of the item description is determined by the customer (sold-to party) language.
Environment
SAP S/4HANA Cloud Public Edition
Cause
This behavior is a new enhancement on CE2508. On previous releases, the item description (Product field) language was determined based on the user logon language for solution orders and service documents.
Resolution
On CE2508, a new behavior was introduced: the item description language is determined by the customer language, instead of the user logon language. The priority for determining the item description language works as bellow:
- The system first uses the customer's language to fetch the product description.
- If the customer's language setting is empty, the system defaults to the current user's language.
See Also
Keywords
solution order, service order, service quotation, wrong language, product description, item description, customer language, user profile language, language determination, 2502, 2508, language, product, user language, logon language , KBA , CRM-S4-SOL-SLO , S4CRM: Solution Order , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem
SAP Knowledge Base Article - Public