SAP Knowledge Base Article - Public

3633859 - User connector - SF is not updating user's security domain

Symptom

After  successfully running User Connector - SF, user's security domain is not being updated.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Fill out connector template with correct information > Upload it to SFTP
  2. Navigate to Learning Administration > System Administration > Connectors
  3. Run 'User Connector - SF' > Check 'View Results' > Completion Status shows 'OK - Success'
  4. Navigate to User's details page > Note that the Security Domain field is not being updated

Cause

In connector property file, domain field is not mapped properly.

Resolution

  1. Navigate to System Administration > Configuration > System Configuration > CONNECTORS
  2. Search for the property sfuser.field.mapping.data.DMN_ID=
  3. Map it to sfuser.field.mapping.data.DMN_ID=DMN_ID

Note: It is suggested to carefully check if there is any extra space in each column in the input file as it might cause problems sometimes.

See Also

2532750 - First record from file is skipped after the User Connector - SF running - SAP for Me

2547179 - User Connector - SF is Not Updating the User's Organization Field - SAP for Me

Keywords

user connector - sf, security domain, domain mapping, connector property file, sfuser.field.mapping.data.DMN_ID, domain, user security domain, user connector , KBA , LOD-SF-LMS-CON , Connectors , Problem

Product

SAP SuccessFactors Learning all versions