Symptom
Learning History is not getting uploaded for users in LMS using the import tool. Import job failed with messages:
- The class ID you specified either does not exist or you do not have permission to use it here.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to System Administration > System Management Tools > Import Data.
- Select Record Type: Learning History >
- Choose Import Option: Add >
- Select the prepared import file and submit
- Job fails with error in downloaded file: "The class ID you specified either does not exist or you do not have permission to use it here."
Cause
There are two possible reasons:
- Learning admin does not have permission to access the class.
- The class does not exist in the system.
Resolution
- For Learning admin permission issues, refer to KBA2647334 for detailed resolution.
- Ensure that the item/class exists in the system before importing learning history via the Import Data tool.
See Also
Keywords
learning history, import tool, class ID, permission issue, item does not exist, error message, import data, learning history, KBA2647334, The class ID you specified either does not exist or you do not have permission to use it here, mass update, import in bulk, class does not exist , KBA , LOD-SF-LMS-IMP , Import Data Tool , Problem
Product
SAP SuccessFactors Learning all versions
SAP Knowledge Base Article - Public