Symptom
- I-9 Reverification task is assigned to incorrect manager when a manager update is made in EC and the Onboarding process is completed.
- This issue is only for completed onboarding process, an open onboarding process does not have this problem.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Onboarding, search for completed onboarding for employee.
- Click on the spotlight card and go to All Actions.
- Select Change Job and Compensation Info.
- Change the Supervisor and Save.
- Refresh the screen, search for this employee again.
- Supervisor is not updated in Onboarding.
Cause
This is a Known Issue.
Resolution
The fix for this issue is planned to be deployed on 1H 2026 release.
For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.
Workaround:
Trigger I-9 Flow in Manage Data to "Correct I-9 Reverification".
Reference guide: Creating a Task to Correct USCIS Form I-9
See Also
- Creating a Task to Correct USCIS Form I-9
- SAP SuccessFactors Product Release & Road Map Information
- SAP SuccessFactors Patches Knowledge Base
- KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs
Keywords
manager changes, EC, onboarding, completed process, I-9 tasks, incorrect managers, compliance, SAP SuccessFactors, Manage Pending Hires, onboarding process, supervisor update, hiring managers, onboarding participants, system design, task assignee, rule US I9 Assign Compliance, OBX, I-9 Reverification, Job Relationship, Known Error, Known Issue, I-9, Correct I-9, OBX-39667, KI1H2505 , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
SAP Knowledge Base Article - Public