Symptom
After instance refresh of production instance to a non production, candidates' emails were not changed to dummy ones.
Environment
SAP SuccessFactors Onboarding
Cause
- "Enable Data Anonymization for Instance Refresh" was not selected when the Instance Refresh was done.
- Please note that we do not entertain script requests after the instance refresh as the customer can perform the action by themselves.
Resolution
Kindly follow the below steps:
- Onboarding module does not anonymize data from this entity. It needs to be validated from customer if they have opted to anonymize all email fields (including EC module as well) during instance refresh. Reference Guide Link: Creating an Instance Refresh Request
Create an RITM to randomly select records from different tables (onboarding’s and EC’s) to understand where all are the non-anonymized email ids.
Reference Query:
SELECT TOP 20 'EC' AS source, EMAIL_ADDRESS FROM <COMPANY_SCHEMA>.EMP_EMAIL_INFO
UNION ALL
SELECT TOP 20 'USER' AS SOURCE , USERS_SYS_EMAIL FROM <COMPANY_SCHEMA>.USERS_SYSINFO
WHERE
USERS_SYS_VALID IN ('e','d') AND USERS_SYS_EMAIL IS NOT NULL
AND
USERS_SYS_ID IN (
SELECT USERS_SYS_ID FROM <COMPANY_SCHEMA>.USERS_INFO WHERE USERS_KEY IN ('$$PERSONTYPE_ONB$$')
)
UNION ALL
SELECT TOP 20 'ONB' AS source, RECIPIENT_EMAIL FROM <COMPANY_SCHEMA>.BE_EF_EMAIL_ADDRESS ;
- Based on the above, suggest customer what step they missed to perform during the Instance Refresh and see whether the customer can redo the refresh with correct steps.
Reference Guide Link: Creating an Instance Refresh Request - If customer can’t repeat the Instance Refresh, suggest the SQL to run so as to anonymized the impacted table. If the emails are not anonymized in the EC/USER Tables, the ticket should be reviewed by EC/User.
See Also
More details on fields supported by onboarding module: Instance Refresh Data Anonymization Fields
Keywords
SAP Knowledge Base Article - Public