Symptom
The "Duplicate" button is active for EDI output messages in the "Manage Output Items" app, when trying to duplicate the output item, it returns an error message "Item '1': 'Duplicate' is not available for channel EDI".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the "Manage Output Items" app.
- When trying to duplicate an EDI output message using the "Duplicate" button.
- Error message "Item '1': 'Duplicate' is not available for channel EDI" occurs.
Cause
EDI messages are part of a business application scenario and, due to technical limitations in the infrastructure, cannot be duplicated—hence, attempting to do so via the "Manage Output Items" app results in a standard system error.
Resolution
- Use the "Change Billing Documents" app to manually add new output lines with the same output type and channel EDI.
- Retry output messages via the "Change Billing Documents" app to set the status to "To Be Output" for proper reprocessing and sending.
See Also
Refer to: Manage Output Items App
Keywords
edi, duplicate, manage output items, change billing documents, sap s/4hana cloud public edition, error status, retry logic, output messages, technical infrastructure, communication scenario , KBA , SD-BIL-GF-OC-2CL , Output Control Billing (Public Cloud) , Problem
SAP Knowledge Base Article - Public