SAP Knowledge Base Article - Public

3634652 - Not possible to duplicate EDI messages in Manage Output Items app - SAP S/4HANA Cloud Public Edition

Symptom

The "Duplicate" button is active for EDI output messages in the "Manage Output Items" app, when trying to duplicate the output item, it returns an error message "Item '1': 'Duplicate' is not available for channel EDI".

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Environment

SAP S/4HANA Cloud Public Edition 

Reproducing the Issue

  1. Open the "Manage Output Items" app.
  2. When trying to duplicate an EDI output message using the "Duplicate" button.
  3. Error message "Item '1': 'Duplicate' is not available for channel EDI" occurs.

         

Cause

EDI messages are part of a business application scenario and, due to technical limitations in the infrastructure, cannot be duplicated—hence, attempting to do so via the "Manage Output Items" app results in a standard system error. 

Resolution

  1. Use the "Change Billing Documents" app to manually add new output lines with the same output type and channel EDI.
  2. Retry output messages via the "Change Billing Documents" app to set the status to "To Be Output" for proper reprocessing and sending.

See Also

Refer to: Manage Output Items App

Keywords

edi, duplicate, manage output items, change billing documents, sap s/4hana cloud public edition, error status, retry logic, output messages, technical infrastructure, communication scenario , KBA , SD-BIL-GF-OC-2CL , Output Control Billing (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions