Symptom
After rejecting/cancelling a sales quote, both header and item statuses remain "Open" instead of "Completed", even though the Reason For Rejection is maintained on the General tab.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the New Business workcenter.
- Go to the Sales Quote view.
- Search for the ID DEF (DEF represents the relevant sales quote ID).
- Open the quote.
- Click on View All.
- Go to the General tab.
There is a Reason for Rejection in place, however the header status is still displayed as Open.
Cause
Through the Business Configuration workcenter - Reasons for Rejection activity (described on the KBA 3323335), the reason for rejection "99 - Cancellation by system (obsolete)" is available by the standard system configuration.
The Sales Quote DEF was cancelled through the sales quotes Object Work List (OWL) via the Actions -> Reject button. However, the selected reason was 99 - Cancellation by system (obsolete), which is an obsolete reason and therefore not valid for cancellations anymore.
Whenever a document is rejected with the Reason 99, such an action will not be reflected to its status.
Resolution
In order to properly complete the Sales Quote DEF, a dummy change must be performed as per the following steps:
- Open the Sales Quote.
- Click on View All.
- On the General tab, remove the selected Reason for Rejection.
- Click on Save.
- Add the Reason for Rejection again and save it.
This way, the system will redetermine the cancellation and the quote will be Completed.
See Also
KBA 3323335 - How to Configure the Options for the Reason for Rejection
Keywords
Cancel, sales quote, not completed, status not reflected, wrong status, inconsistent, rejected, open, byd. , KBA , AP-SLO-SO , Sales Order , How To
SAP Knowledge Base Article - Public