SAP Knowledge Base Article - Public

3634826 - Changes in a case updated by CX AI Toolkit are showing the wrong user

Symptom

After updating a case via CX AI Toolkit Service Classification Agents playground, the user showed on the changes tab is the one testing the agent, not the configured technical user for CX AI Toolkit.

Environment

  • SAP CX AI Toolkit
  • Sales and Service Cloud V2

Reproducing the Issue

  1. In CX AI Toolkit open AI Agents tab
  2. Click on the three dots on the desired agent
  3. Go to Playground
  4. Input desired case to update
  5. Press Generate
  6. On Sales Service Cloud V2, see that the user attributed to the changes on the case is not CX AI Toolkit technical user

Cause

This is the standard functionality of the system.

Resolution

The changes are only attributed to CX AI Toolkit when the agent is triggered automatically. If the change is triggered by user input on the Playground it will be displayed as having been done by the user.

Keywords

KBA , CEC-AIT-CRM , Sales/Service AI Tools, Meetings, Email, and Scheduling , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0