SAP Knowledge Base Article - Public

3634995 - Error 'login.microsoftonline.com refused to connect' on content launch

Symptom

Users encountered an error "login.microsoftonline.com refused to connect" when launching OCN course content in an inline window.

Environment

SAP SuccessFactors Learning 

Reproducing the Issue

  1. Navigate to Learning >
  2. Search for the OCN course, and open >
  3. Start Course and launch content >
  4. Encounter an error stating 'login.microsoftonline.com refused to connect'.

Cause

Microsoft's security configuration prevents their page from being embedded in other pages.

Resolution

As this is controlled by the Microsoft, SAP SuccessFactors Learning does not have the ability to alter this setting. To ensure that you can access the OCN content, it is recommended to configure third-party or external content to launch in a new window. 

Here are the steps to do this:

  1. Access Learning Administration >
  2. Navigate to Content > Content Objects >
  3. Search for the relevant content object and open it in edit mode >
  4. Select 'Launch Method' and check/enable the setting 'Launch in a new browser window' >
  5. Apply Changes. 

Once these steps are completed, users will be able to launch the content, and content will open in a new window.

See Also

Keywords

SuccessFactors learning, x-frame, refused to display URL, inline window, ocn course, go1, LinkedIn, launch error, authentication, new window, security configuration, third-party content, external content, login.microsoftonline.com refused to connect, Launch in a new browser window , KBA , LOD-SF-LMS-OCN , Open Content Network , Problem

Product

SAP SuccessFactors Learning all versions