Symptom
Users encountered an error "login.microsoftonline.com refused to connect" when launching OCN course content in an inline window.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to Learning >
- Search for the OCN course, and open >
- Start Course and launch content >
- Encounter an error stating 'login.microsoftonline.com refused to connect'.
Cause
Microsoft's security configuration prevents their page from being embedded in other pages.
Resolution
As this is controlled by the Microsoft, SAP SuccessFactors Learning does not have the ability to alter this setting. To ensure that you can access the OCN content, it is recommended to configure third-party or external content to launch in a new window.
Here are the steps to do this:
- Access Learning Administration >
- Navigate to Content > Content Objects >
- Search for the relevant content object and open it in edit mode >
- Select 'Launch Method' and check/enable the setting 'Launch in a new browser window' >
- Apply Changes.
Once these steps are completed, users will be able to launch the content, and content will open in a new window.
See Also
Keywords
SuccessFactors learning, x-frame, refused to display URL, inline window, ocn course, go1, LinkedIn, launch error, authentication, new window, security configuration, third-party content, external content, login.microsoftonline.com refused to connect, Launch in a new browser window , KBA , LOD-SF-LMS-OCN , Open Content Network , Problem
SAP Knowledge Base Article - Public