SAP Knowledge Base Article - Public

3635435 - Approval Button Is Not Available In The Email When It Is Triggered Through The Sales Contract Process

Symptom

  • Upon triggering the approval process for a sales contract in the SAP C4C system, the corresponding notification emails received in Outlook do not display the expected action buttons such as "Approve" or "Send Back for Revision".
  • Users are required to log in to the SAP C4C system to perform approval actions, which is not aligned with the expected functionality.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Contracts Work Center .
  2. Search & open Contract ABC (Document Type as "Sales Contract").
  3. Submit the contract for approval.
  4. Check the email received in Outlook.
  5. Observe that the email does not include the expected "Approve" or "Send Back for Revision" buttons.

Cause

  • Missing functionality: The email approval feature is not implemented for the Sales Contract business object.

Resolution

The Approval Via E-mail functionality is not available for Contracts.

C4C only supports Approval via E-mail for the following Sales documents:

  • Opportunity 
  • Sales Quote
  • Sales Order

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

See Also

Keywords

contract, approval via e-mail, email, approval, sales quote, opportunity, SAP Cloud for Customer, Sales Contract. , KBA , LOD-LE-COP , Contract Processing , LOD-LE-COP-SLS , Sales Contract , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2505