Symptom
How to exclude 2 digits accounts from the approval process for invoices.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management work center.
- Under Task Distribution view, select Approval Processes subview.
- Under Related Business Document: Customer Invoice (1), select the respective Approval Process.
- Click in Copy.
- Under Conditions, select Add Group.
- Select Field Buyer Party.
- In the Compare Operator, select Matches pattern With Value 2+.
Although the invoice documents are generated in accordance with the defined rule, they are still being sent for approval. This behavior contradicts the specified condition, which is intended to exclude all accounts containing two digits.
Cause
This is the expected system behaviour.
Resolution
In order to exclude all account ID's containing two digits, it is necessary to configure a separate condition for each individual account ID.
Please refer to the below steps:
- Go to Application and User Management work center.
- Under Task Distribution view, select Approval Processes subview.
- Under Related Business Document: Customer Invoice (1), select the respective Approval Process.
- Click in Copy.
- Under Conditions, select Add Group.
- Select Field Buyer Party.
- In the Compare Operator, select Equal To with Value e.g 11 (Where 11 represents a 2 digits account ID).
- Click in Add Group and add another Buyer Party ID.
- Repeat this process until all accounts which should be excluded from the approval process is maintained.
See Also
Help Center Documentation: Create and Edit an Approval Process
Keywords
Does not exist, does not available, approval processes, account ID's, multiple. , KBA , SRD-CRM-INV , Customer Invoicing , How To
SAP Knowledge Base Article - Public