Symptom
The Payment Method field under the Automatic Payment Transaction section allows only one payment method to be entered in the Fiori apps.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the "Manage Business Partner Master Data App."
- Find and open a Business Partner ID.
- Navigate to the "Company Codes" tab.
- Select more details of the Company Codes.
- Scroll to the "Finance" section and locate the "Automatic Payment Transaction" area.
- In the "Payment Method" field, attempt to enter multiple payment methods.
- Observe that only one payment method can be entered, even when using the help/suggestion function.
Cause
The Fiori apps, including "Manage Business Partner Master Data App," "Manage Customer Master Data App," and "Manage Supplier Master Data App," are designed as lighter versions for specific use cases. These apps include only the most commonly used fields and do not support maintaining multiple payment methods.
Resolution
Use the "Maintain Business Partner" app to maintain multiple payment methods.
- Open the "Maintain Business Partner" app.
- Open the relevant Business Partner (BP).
- Display the BP in the role of Supplier (Financial Accounting) or Customer (Financial Accounting).
- Navigate to the "Company Code" tab.
- Navigate to the "Supplier: Payment Transactions" tab.
- Under the "Automatic Payment Transaction" section, maintain multiple payment methods.
Keywords
manage business partner, f3163, sap s/4hana public cloud, payment methods, automatic payment transaction, fiori apps, maintain business partner, multiple payment methods, supplier financial accounting, customer financial accounting, company code, sap central business configuration, master data maintenance, sap s/4hana , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem
SAP Knowledge Base Article - Public