SAP Knowledge Base Article - Public

3635757 - Global Search not displaying accurate results when searching by username

Symptom

  • Multiple results appear in the People Search when searching for an employee by username.
  • The search result is not accurate, displaying user in the middle of user's list.
  • You notice that it does not apply to all your searches, few usernames results are properly displayed in first line. 
  • Why not all searches display precise results as first option when you use usernames?

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Perform a People Search using a username.
  2. Observe the position of the employee in the search results is not always the first option.

Cause

  • The issue arises due to the configuration of the Solr-based person search, which assigns the same weight to fields such as username, firstname, lastname, and generalDisplayName.
  • When fuzzy search is enabled, the query considers partial matches and variations, which can result in higher scores for employees with multiple matching fields.
  • For example, an employee with a generalDisplayName and lastname matching the query may score higher than an employee with only the username matching.

Resolution

Currently, our Solr-based person search does not support both fuzzy search and exact match at the same query.

However, we are developing an enhanced person search based on Elastic search, which will provide more powerful and comprehensive search capabilities.

You can follow the roadmap of the enhanced person search: SAP Road Map Explorer

See Also

Keywords

people search, username search, search results order, fuzzy search, solr search, sap successfactors platform, search index, inconsistent search results, employee search, search behavior , KBA , LOD-SF-PLT-SRH , Search , Product Enhancement

Product

SAP SuccessFactors Platform 2505