SAP Knowledge Base Article - Public

3635944 - Cannot Save Business Rules for i9 in Compliance Setting - Onboarding

Symptom

When user tries to create and save Business Rules for i9 in Compliance Settings for US candidates, rules are removed after refreshing the page. 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to the compliance configuration for the United States.
  2. Attempt to assign the business rules for I9:
    • Select rule I-9 Enablement
    • Select rule Corporate Representative
  3. Refresh the page.
  4. Observe that the selected rules are removed.

Cause

Multiple duplicate configurations in Manage Data> ComplianceConfiguration which causes conflicts when attempting to assign business rules.

Resolution

  1. Navigate to "Manage Data" > "ComplianceConfiguration".
  2. Identify and review the existing compliance configurations for US_I9.
  3. Retain only one valid compliance configuration and delete the duplicates.
  4. Reassign the business rules for I-9 Enablement & Corporate Representative in the Compliance Setting for I9:
  5. Refresh page and verify that the rules remain attached after refreshing the page.

See Also

Keywords

i9 business rules, compliance configuration, us_i9, duplicate compliance configurations, business key values already exist, coe_general_bad_request, onb2_trigger_i9, onb2_assign_i9_responsible_group, compliance forms, sap error 400, compliance metadata sync, sap provisioning, compliance corporate representative. , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem

Product

SAP SuccessFactors Onboarding all versions