Symptom
When user tries to create and save Business Rules for i9 in Compliance Settings for US candidates, rules are removed after refreshing the page.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to the compliance configuration for the United States.
- Attempt to assign the business rules for I9:
- Select rule I-9 Enablement
- Select rule Corporate Representative
- Refresh the page.
- Observe that the selected rules are removed.
Cause
Multiple duplicate configurations in Manage Data> ComplianceConfiguration which causes conflicts when attempting to assign business rules.
Resolution
- Navigate to "Manage Data" > "ComplianceConfiguration".
- Identify and review the existing compliance configurations for US_I9.
- Retain only one valid compliance configuration and delete the duplicates.
- Reassign the business rules for I-9 Enablement & Corporate Representative in the Compliance Setting for I9:
- Refresh page and verify that the rules remain attached after refreshing the page.
See Also
- Refer to: KBA 3459567 - Configuring USCIS Form I-9 - Onboarding.
- Refer to: Configuring USCIS Form I-9.
Keywords
i9 business rules, compliance configuration, us_i9, duplicate compliance configurations, business key values already exist, coe_general_bad_request, onb2_trigger_i9, onb2_assign_i9_responsible_group, compliance forms, sap error 400, compliance metadata sync, sap provisioning, compliance corporate representative. , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
SAP Knowledge Base Article - Public