SAP Knowledge Base Article - Public

3636226 - Email Delivery Fails Initially with DKIM or DMARC Policy Error but Succeeds on Retry.

Symptom

  • Business emails sent from C4C to end recipients are intermittently failing or getting rejected.
  • Email delivery failures are linked to DKIM or DMARC authentication failures, as observed from DNS and email server logs.
  • When the user resends the same email from C4C to the same recipient, the email is successfully delivered.

Note: Valid DKIM is maintained by the customer, and the respective domain is activated on the SAP side. This issue occurs intermittently.

Environment

SAP Cloud For Customer.

Reproducing the Issue

  • Navigate to any views such as Sales Orders, Tickets or any Business Emails view
  • Send an email to xyz.com 

Email is not received by xyz.com

Cause

This issue primarily occurs when the receiving email server or the end recipient is Microsoft Office 365.

Background: When an email is received by Microsoft Office 365 servers, the email server sometimes takes more than 60 secs to resolve the DKIM signature validation. Hence it times out. 

Resolution

  • The issue originates from Microsoft’s side, and therefore, SAP cannot provide direct assistance in this matter.
  • We recommend that the customer reach out to Microsoft support for further investigation and resolution.

Workaround: We recommend the system administrator to track the failed email logs and re-send emails.

Keywords

DKIM Failed, DMARC Failed, Microsoft Office 365. , KBA , LOD-CRM-ADM , Administration UI , Problem

Product

SAP Cloud for Customer core applications all versions