SAP Knowledge Base Article - Public

3637028 - Billing Documents Blocked for Accounting - S/4Hana Public Cloud

Symptom

When posting a billing document to financial accounting, you see an error message stating that "G/L Account XXX requires a valid tax code". 

Reproducing the Issue

In the following cases, billing documents are blocked for posting (release) to financial accounting:

  • If errors occur in account determination. For more information about these errors, see Analyzing Errors in Revenue Account Determination

  • If the billing document is incomplete (for example, if the customer master record of the payer has not yet been maintained by the accounting department)

  • If errors occur in pricing

Cause

There's a check in place for billing documents sent to the financial accounting interface. When these documents are posted, the system checks whether the general ledger account to which they should be posted is tax-relevant or not. If the account is tax-relevant, the system checks to see whether a tax code is in the document. If there's no tax code, the system raises this error message, letting you know that the account requires a valid tax code.

Resolution

If you see the message when you're posting billing documents, you must verify that the documents have the correct tax information and post them again. You can also use the Manage G/L Account Master Data app to see the tax category assigned to the G/L account, which can help you verify that the tax code on the billing document matches the tax conditions of the G/L account.

Note: If the billing document has not been posted to financial accounting because of errors, you can post it to find out what errors occurred.

See Also

Keywords

release, accounting, posting, billing document, G/L, tax code, financial, VF01, VF02, Manage G/L Account Master Data, S/4Hana public cloud , KBA , SD-BIL-2CL , Billing (Public Cloud) , FI-GL-GL-2CL , Basic Functions (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition 2502