SAP Knowledge Base Article - Public

3637090 - "Failed to Fetch Data" Error in Console Despite Successful Data Load

Symptom

  • A "Failed to fetch the data" error appears briefly (for a few seconds) during data loading.
  • Despite the error, the data eventually loads successfully for the selected time period.
  • The error is not visible in the front-end UI of the story, users do not see any error message on the screen.
  • The issue is only detectable via console traces (browser developer tools).

Environment

  • SAP ANALYTICS CLOUD 2025.14.1
 

Reproducing the Issue

  1. Open the affected SAP Analytics Cloud (SAC) story in view mode.

  2. In Google Chrome, open the Developer Tools:

    • Go to More Tools > Developer Tools, or use the shortcut Ctrl+Shift+I.

  3. Navigate to the Console tab to monitor console logs.

  4. In the story, locate the "Reporting Period" dropdown in the top-right corner (just below the Edit/View button).

  5. Change the reporting period by selecting any available Month-Year value (e.g., Apr 2025).

  6. Observe the console:

    • A "Failed to fetch the data" error appears briefly (for a few seconds) in Console traces.

    • Despite this, the data loads successfully, and no error is shown in the story’s front-end UI.

Cause

This issue was identified as bug and code-correction has fixed the issue.

Resolution

The fix will be deployed as a part of the next quarterly release cycle (November 14-16).

Release dates for SAP Cloud Products are available at the following KB: SAP ONE Support Launchpad

Keywords

SAC, error, console, "Failed to fetch the data", reporting, period, developer tools, data load, story , KBA , LOD-ANA-DES , Story Design & Visualizations , Problem

Product

SAP Analytics Cloud 1.0