Symptom
After scheduling an interview for a candidate, the candidate does not receive the notification email for the Candidate Self-Schedules Interview notification.
Image / Data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Navigate to the Interview Scheduling page
- Schedule an interview for the candidate
- Select the interviewer and time slot
- Click on the "Continue" button
- "Contact Candidate" window pops up with the email template configured for trigger "Candidate Self-Schedules Interview"
- Click on the "Send to Candidate" button to send the email notification
- Observe that the candidate does not receive the email
Cause
The SPF record is not configured for the interview originator's email address.
Resolution
When sending the Candidate Self-Schedules Interview trigger notification from the Interview Scheduling tool, the "sender name" will be the email address of the interview originator in the User Data File(UDF).
The "sender name" is displayed at the top left of the "Contact Candidate" window.
If the sender's domain is not configured with an SPF record, the email will be blocked by public mail services like Gmail.
Add the SAP SuccessFactors SPF record to the DNS if the originator's email domain differs from the SAP SuccessFactors sender domain.
Refer to the KBA 2087468 - Emails Blocked or Not Delivered Due to Spam Filters, Spoofing, Bombing (mass mail), IP Address Allowlists.
See Also
2087468 - Emails Blocked or Not Delivered Due to Spam Filters, Spoofing, Bombing (mass mail), IP Address Allowlists
Keywords
email block, SPF, DKIM, interview trigger, candidate interview, interview scheduling , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem
SAP Knowledge Base Article - Public