Symptom
The "Is Contact Person for" option is missing in the dropdown of the Relationship tab for Account and Individual Customer in SAP Cloud for Customer.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Navigate to Customers.
- Select Individual Customers.
- Open any Customer.
- Go to the Relationship tab.
- Choose to Add a Relationship.
- Observe that the "Is Contact Person for" option is missing in the dropdown.
Cause
The "Is Contact Person for" option is not available in the Individual Customers UI by design, as it can only be assigned to Contact Persons. Individual Customers are generally not considered Contact Persons.
Resolution
- To assign the "Is Contact Person for" option, use the Contacts UI instead of the Individual Customers UI.
- Add the action "Add Contacts" to the Contacts tab within the Account UI to enable this functionality.
See Also
Keywords
missing dropdown option, is contact person for, individual customer, account, sap cloud for customer, c4c, contact person assignment, dropdown issue, sap service cloud, account and contacts, relationships, ui design limitation, contact ui , KBA , LOD-CRM-ACC , Account , Problem
SAP Knowledge Base Article - Public